Buildings down for network maintenance.

Incident Report for UNC Chapel Hill - ITS

Resolved

This incident has been resolved.
Posted Dec 16, 2025 - 11:51 EST

Investigating

There are several buildings currently down for network maintenance. Joan H. Gillings Center for Dramatic Arts, Hortense King McClinton Hall, Stacy Residence Hall, Everett Residence Hall, Lewis Residence Hall and Renee Lynne Ct, 101.
Posted Dec 16, 2025 - 10:01 EST
This incident affected: Other Services.